מאמרים אחרונים

שתף בפייסבוק שיתוף בפייסבוק
RSS - מאמריםמאמרים
RSS - פורומיםפורומים
דווח למנהל דיווח למנהל
קישור לעמוד זה קישור לעמוד זה
עוד בקבוצת HT



שליטה על מפסקי BROADLINK TC2 (נמצא פתרון)


עמוד 4 מתוך 6
עבור לעמוד הקודם  |  1  |  2  |  3  |  4  |  5  |  6  |  הבא 
   פורומים > HT Home > עוזרות קוליות, שליטה ובקרה
מחבר הודעה
NightRanger
חבר פעיל
חבר פעיל

הצטרף בתאריך:
  Feb 12, 2011
הבעות תודה: 15
מספר הודעות: 76

 #46  נשלח: ג' 03/01/2017 1:47

adiz
·
כן גם עם אלקסה ו ha bridge
וגם עם סירי ו homebridge

שתי הקונפיגורציות שולחות לבסוף את הפקודה לביצוע ל RM PRO
פרופיל | שלח הודעה | חפש
karpe
חבר ותיק
חבר ותיק


הצטרף בתאריך:
  Jun 04, 2006
הבעות תודה: 136
מספר הודעות: 1288

 #47  נשלח: ג' 03/01/2017 2:14

אני לא מצליח בינתיים גם עם הRM3, יש לי את הקודים של הפקודות, אני לא ממש מבין מה להכניס בשדות של הקינפוג בברידג', כשאני עושה MANUAL ADD.
יש את הON URL וOFF URL ששם אני מניח ששמים את הכתובת של הפקודה המקוצרת עם הIP הקבוע של האנדרואיד והפורט של האפליקציה, יחד עם השם של הפקודה שלימדתי אותו. מה שמים בHTTP HEADER ומה בHTTP VERB ואז בפורמט ובCONTENT BODY ON/OFF?
פרופיל | שלח הודעה | חפש
NightRanger
חבר פעיל
חבר פעיל

הצטרף בתאריך:
  Feb 12, 2011
הבעות תודה: 15
מספר הודעות: 76

 #48  נשלח: ג' 03/01/2017 10:17

karpe
·

קודם כל תוודא שאתה עוקב אחרי ההוראות כאן כדי שתהיה תמיכה ב rm 3

http://fun2code-blog.blogspot.co.il/2016/07/rm3-mi...

ב ha-bridge תגדיר שם לפעולה (זה המשפט שתגיד לאלקסה)

בסוג תבחר custom

תכניס את ה on/off URL ל rm bridge

צריך לבחור את שיטת השליחה post או get
לפי הדוקומנטציה שתי השיטות נתמכות אבל נראה לי שעדיף לך להשתמש ב get

אחרי שאתה מלמד את הפקודה ה rm bridge אמור לייצר לך את ה URL, אם תיגש אליו באמצעות הדפדפן אתה גם תראה את ה response

זה מה שאתה צריך להכניס ב ha-bridge

יכול להיות שאני טועה (הכל מזיכרון, כותב את התגובה מהסלולארי) אצלי ה rm bridge לא עובד בכלל.

בהצלחה!
פרופיל | שלח הודעה | חפש
adiz
חבר פעיל מאוד
חבר פעיל מאוד

הצטרף בתאריך:
  Apr 21, 2006
הבעות תודה: 4
מספר הודעות: 416

 #49  נשלח: ג' 03/01/2017 17:17

NightRanger

אז בעצם חייבים את ה Rm Pro - לא ניתן לשלוח פקודות web באמצעות אלקסה ישירות למפסקים?

תודה.
פרופיל | שלח הודעה | חפש
NightRanger
חבר פעיל
חבר פעיל

הצטרף בתאריך:
  Feb 12, 2011
הבעות תודה: 15
מספר הודעות: 76

 #50  נשלח: ג' 03/01/2017 17:21

adiz
·
נכון, ה rm pro יודע לעבוד ב ir ו rf (המפסקים הם rf)
433/315 MHz אם אני לא טועה.
פרופיל | שלח הודעה | חפש
karpe
חבר ותיק
חבר ותיק


הצטרף בתאריך:
  Jun 04, 2006
הבעות תודה: 136
מספר הודעות: 1288

 #51  נשלח: ג' 03/01/2017 20:35

טוב, התקדמתי עוד קצת. כרגע יש לי בHA BRIDGE, בדף של BRIDGE DEVICES שורה עם פקודה שנקראת HEAT, וכשאני לוחץ TEST ON או TEST OFF המזגן נדלק ונכבה (דרך הRM BRIDGE והRM MINI).
בשלב הבא אני אמור לפתוח את ההגדרות של אלקסה, לעשות DISCOVER DEVICES בדף של SMART HOME ואז לראות שנוספו פקודות חדשות.
כשאני עושה את זה אני מקבל הודעה :

Discovery could not be completed. All of your Alexa devices are offline.

למרות שהדוט עובדת ומחוברת ומופיעה כONLINE בדף של הSETTINGS. פה נתקעתי..ניסיתי להוציא את הדוט מהחשמל ולהחזיר, לא עוזר.
ניסיתי גם להגיד לה ALEX DISCOVER DEVICES, והיא גילתה את מה שכבר היה, לא נוסף שום דבר חדש.
רעיונות?
פרופיל | שלח הודעה | חפש
NightRanger
חבר פעיל
חבר פעיל

הצטרף בתאריך:
  Feb 12, 2011
הבעות תודה: 15
מספר הודעות: 76

 #52  נשלח: ג' 03/01/2017 20:42

karpe
·
אולי ה firewall של מערכת ההפעלה פעיל, תנסה לבטל אותו לצורך הבדיקה אם זו הבעיה תחזיר אותו ותוסיף את הפורט של ha-bridge לרשימת הפורטים המאושרים ב firewall

וכמובן שים לב שהאקו וה ha על אותה הרשת
פרופיל | שלח הודעה | חפש
karpe
חבר ותיק
חבר ותיק


הצטרף בתאריך:
  Jun 04, 2006
הבעות תודה: 136
מספר הודעות: 1288

 #53  נשלח: ג' 03/01/2017 20:52

כמובן שהכל על אותה רשת, ניסיתי לכבות את הפיירוול במחשב, לא עזר
פרופיל | שלח הודעה | חפש
NightRanger
חבר פעיל
חבר פעיל

הצטרף בתאריך:
  Feb 12, 2011
הבעות תודה: 15
מספר הודעות: 76

 #54  נשלח: ג' 03/01/2017 21:02

karpe
·
נראה שעשית הכל כמו שצריך, ההבדל אצלי הוא שאני מריץ את ha bridge על פורט 80 על רספברי פיי
תבדוק את ה upnp אולי קשור איכשהו , תבדוק אם פעיל בראוטר שלך
פרופיל | שלח הודעה | חפש
karpe
חבר ותיק
חבר ותיק


הצטרף בתאריך:
  Jun 04, 2006
הבעות תודה: 136
מספר הודעות: 1288

 #55  נשלח: ה' 05/01/2017 0:29

התקדמתי אבל לא בכיוון הרצוי. עדיין אלקסה לא מזהה לי את הפקודות מהברידג'.
בדקתי שUPNP פעיל בראוטר, עשיתי לו ריסט, לא עזר.
מה שכן הצלחתי זה להוסיף פקודות בדידות של הרמוני לHA BRIDGE ! מסתבר שזה הרבה יותר פשוט ממה שחשבתי..
בטאב של BRIDGE CONTROL יש שדה של הרמוני, צריך פשוט לתת לו שם כלשהו, ואת כתובת הIP (שצריכה להיות מקובעת בראוטר).
מה שחשוב בשלב הזה - ללחוץ על הכפתור הירוק למעלה SAVE !
ואז יופיעו שני טאבים חדשים : HARMONY ACTIVITIES והHARMONY DEVICES. מכאן זה פשוט - אפשר לכל אקטיביטי ולכל פקודה של מכשיר ללחוץ על הכפתור הירוק שליד, מה שיפתח למטה שדה חדש שבו צריך לעדכן את השם של הפקודה (שזה מה שישמש להפעלה מאלקסה), ולעשות ADD BRDIGE DEVICE. ואז בטאב של BRDIGE DEVICE היא תופיע, אפשר לבדוק אותה ע"י TEST ON. אצלי הפקודות עובדות במצב הזה של בדיקה, אבל אלקסה לא מזהה את הפקודות החדשות עדיין.. פה אני תקוע.
פרופיל | שלח הודעה | חפש
NightRanger
חבר פעיל
חבר פעיל

הצטרף בתאריך:
  Feb 12, 2011
הבעות תודה: 15
מספר הודעות: 76

 #56  נשלח: ה' 05/01/2017 0:45

karpe
·
ממש מבאס, אצלי היא זיהתה ממש ללא בעיות, לצערי לא מצליח לחשוב על עוד משהו הפיירוול וה upnp היו כיוונים טובים.
אצלי ה ha-bridge מותקן על raspberry pi שמערכת ההפעלה שלו היא בעצם לינוקס ואת ה ha-bridge אני מריץ על פורט 80 זה ההבדל היחיד.

בעצם...כיוון אחרון...יש לך אנטיוירוס ?
אם כן תנסה לבטל אותו לפעמים הם גורמים לבעיות לא צפויות (למרות שתאורטית לא אמור להיות קשר)

תעדכן...
פרופיל | שלח הודעה | חפש
karpe
חבר ותיק
חבר ותיק


הצטרף בתאריך:
  Jun 04, 2006
הבעות תודה: 136
מספר הודעות: 1288

 #57  נשלח: ה' 05/01/2017 0:52

אין אנטיוירוס..

נראה לי שהכיוון הוא אכן הפורט 80. בדף של הHA כתוב :


-Dserver.port=<port number>
The default port number for the bridge is 80. To override what the default or what is in the configuration file for this parameter, specify -Dserver.port=<port number> explicitly. This is especially helpful if you are running the ha-bridge for the first time and have another application on port 80. The command line example:

java -jar -Dserver.port=80 ha-bridge-W.X.Y.jar

Note: if using with a Google Home device, port 80 must be used.



אולי גם הדוט פונה לפורט 80 בלבד כדי למצוא רכיבים חדשים?

בדקתי בNETSTAT מי תופס לי את פורט 80, וזה פרוסס של NT KERNEL במחשב, אז אני לא רואה דרך לפנות אותו..
אולי אתה יכול לנסות לשנות אצלך לפורט 8080 ולראות אם עדיין מזהה לך?
פרופיל | שלח הודעה | חפש
NightRanger
חבר פעיל
חבר פעיל

הצטרף בתאריך:
  Feb 12, 2011
הבעות תודה: 15
מספר הודעות: 76

 #58  נשלח: ה' 05/01/2017 0:58

karpe
·

כן, אנסה מחר בבוקר ואעדכן
פרופיל | שלח הודעה | חפש
karpe
חבר ותיק
חבר ותיק


הצטרף בתאריך:
  Jun 04, 2006
הבעות תודה: 136
מספר הודעות: 1288

 #59  נשלח: ה' 05/01/2017 1:23

טוב, בדקתי את מצב הפורטים על מחשב אחר - מיניקס Z64, ושם פורט 80 היה פנוי. אז הרצתי את הסרבר עליו, עם פורט 80, והרבה תקווה.. ויוק - לא מוצאת עדיין. איזה עצבים, כל כך קרוב.. בכל מקרה אני אשמח אם תנסה ותעדכן.
פרופיל | שלח הודעה | חפש
karpe
חבר ותיק
חבר ותיק


הצטרף בתאריך:
  Jun 04, 2006
הבעות תודה: 136
מספר הודעות: 1288

 #60  נשלח: ה' 05/01/2017 1:32

רגע רגע. האם כדי שהעסק יעבוד אני צריך גם לאפשר PHILIPS HUE SKILL? הרי הברידג' אמור לדמות נורות HUE..
זה לא היה מאופשר אצלי. אז איפשרתי, פתחתי חשבון בHUE, ואז הוא ניסה למצוא ברידג' של HUE ולא מצא, המשכתי בכל זאת, נתתי לאלקסה שוב לסרוק, ושוב לא מצאה כלום חדש... מה פספסתי פה?
פרופיל | שלח הודעה | חפש
כל הזמנים הם שעון קיץ - ישראל (GMT+3) הצג הודעות קודמות:    
פורומים > עוזרות קוליות, שליטה ובקרה עבור לעמוד הקודם  |  1  |  2  |  3  |  4  |  5  |  6  |  הבא 


  
    שם משתמש:
נתוני כניסה לכל אתרי HT:

  סיסמא:
 

  


 | 

קפוץ אל: 
לא ניתן לשלוח הודעות בפורום זה
לא ניתן להגיב להודעות בפורום זה
לא ניתן לערוך את הודעותיך בפורום זה
לא ניתן למחוק את הודעותיך בפורום זה
לא ניתן להצביע לסקרים בפורום זה
לא ניתן לצרף קבצים בפורום זה
לא ניתן להוריד קבצים בפורום זה

תקנון / תנאי השימוש באתר צור קשר / contact us כל הזכויות שמורות לקבוצת ht